Arexico

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Delayed invoice processing
Resolved·Degraded performance

Immediate invoice issuance has been restored, and previously delayed invoices have now been issued as well. If you got any questions, do not hesitate to reach out to support@arexico.com.

Sat, May 30, 2026, 11:00 AM
(3 months ago)
·
Affected components
Apr 25, 2026, 04:00 PM
May 15, 2026, 11:00 AM
Updates

Resolved

Immediate invoice issuance has been restored, and previously delayed invoices have now been issued as well. If you got any questions, do not hesitate to reach out to support@arexico.com.

Sat, May 30, 2026, 11:00 AM

Identified

We are currently experiencing delays in the processing of invoices for payments made to our German entity. We are working on a solution. If you have not received an invoice for a payment after 14 days, please reach out to our team at support@arexico.com. We are sorry for the inconvenience.

Sat, Apr 25, 2026, 04:10 PM(1 month earlier)